Установка зависимостей на автомате

Внутри этого раздела все зависимости предлагалось ставить с помощью npm install <имя_пакета>, но есть более удобный способ — использовать плагин для webpack — npm-install-webpack-plugin (на данный момент версии 4.0.5)

npm install npm-install-webpack-plugin --save-dev

Плагин будет анализировать наши файлы на предмет зависимостей и устанавливать новые пакеты, если обнаружится неизвестная зависимость. Главное, не забывайте удалять лишние пакеты, если будете экспериментировать и пробовать разные.

.npmrc

save=true
save-exact=true

webpack.config.js

...
// добавьте новую зависимость в начале конфига
var NpmInstallPlugin = require('npm-install-webpack-plugin');
...
// добавьте плагин в секцию плагинов
plugins: [
    new webpack.HotModuleReplacementPlugin(),
    new NpmInstallPlugin() // <--
  ],
...

Далее в руководстве все равно будут употребляться npm install, так как это визуально дает хорошее представление о том, какие зависимости нам нужны. Если вы поставили и настроили npm-install-webpack-plugin, то можете не беспокоиться и пропускать эти строки.

Код данного раздела

results matching ""

    No results matching ""